Start Clock



  • My brother and I are trying to setup our own private server to race on. Is there any way to get the start clock to work on this server? Thanks.


  • registered-users

    Are you running a dedicated server or just hosting in game?



  • I've tried both. I'm still working on connecting to the dedicated server.



  • If your hosting a dedicated server and try to connect to it on the same computer, you'll get a Join Timed Out message and won't be able to connect to it. You'll need a separate computer to run a server and be able to race on it at the same time with your main computer.

    As for the start clock, I'm assuming it would work on a server without doing anything special.


  • registered-users

    Actually, I think you can connect to a dedicated server running on the same machine, you just cannot connect via selecting it from the race list. If it's on the same computer you can click the + and add 127.0.0.1 as the IP address and you should, in theory, be able to connect to it.

    Same if you're running a server on another computer that's on the same router, you'd have click the + and type in the IP address that your router assigned to the computer that's running the server. Typically 192.168.x.x People outside your router (on the internet) should be able to connect to it fine if ports are opened correctly on your router.

    Steach can probably point you in the right direction for the ports as he just got a server setup.



  • Thanks! The IP trick worked. I can now connect to the serer.



  • Aaaaaaaaaaannndd......

    The clock still won't work.
    Unless I'm doing something horribly wrong. Or you need more than one person, which I think you shouldn't. Probably.


  • registered-users

    The clock should show up if you switch to race session, there isn't anything special about the server. Does it work when you run on the UHL server?

    It should also work if you just do a single player race and change to race session, the start clock should show up. Make sure there's no AI drivers, they might make the game freeze/crash.

    If the clock isn't showing up, make sure you have the Hydroplane Mod selected as the race series. Also make sure you have latest DirectX9 runtime installed.



  • Direct X9 will not work on Windows 10. I tried a different DirectX Runtime from a different Support topic, but that will not work.


  • registered-users

    I certainly have installed the DirectX9 runtime on my Windows 10 machine. I'm not sure if it was from that link or not though.

    The clock won't render without it. Next update to the mod I'll include the directx dll that is required.



  • Alright, thanks :)

    We'll have to make do without it for now, then.



  • What is the list of files that I should have?



  • This post is deleted!


  • This post is deleted!


  • Still no clock.



  • I might be missing something else important.


  • registered-users

    Just curious, is rFactor currently configured to run with DirectX9?

    Run rFactor Config from start menu and make sure DirectX9 is selected in the drop down.

    I honestly don't know what the list of files you need is, I've never had a problem getting the clock to work. All I did was install the latest DX9 runtime libs.



  • This post is deleted!


  • Merry Christmas! So, I now have a new computer. I installed rFactor and HydroMod and tested it out. The clock still doesn't work. I made sure to have DX9 setup in the Config, and I even ran the game as an administrator. Still nothing.


Log in to reply
 

Looks like your connection to Unlimited Hydroplane League was lost, please wait while we try to reconnect.