Happy 4th of July! HydroSim Alpha v0.5.1.0


  • registered-users

    Happy 4th of July! An update is finally here!

    v0.5.1.0

    Updates:

    • New replay menu that has boat / camera selectors and current time.
    • Added loading / transition screens.
    • Add support for loading other race courses.
      • Added course selection menu to the main menu.
      • Added course selection to server admin menu.
    • Added Guntersville course.
    • Made performance optimizations.
    • Added more detail to San Diego.
      • Terrain now uses MicroSplat materials / shaders. Also using new textures.
      • Using EasyRoads Asset for creating roads / bridges.
    • Added some more boats to choose from.

    Fixed

    • Fixed bugs with leaving the server and re-connecting without restarting the game.
    • More dedicated server fixes (still trying to get the timing issues sorted out).
    • Various other bug fixes.

    Download HydroSim v0.5.1.0 (Windows)

    Newer build available here


  • registered-users

    There seems to be a bug when changing courses while connected to the server. It sometimes gets stuck at the "synchronizing buoys..." screen. I'm looking into it.


  • registered-users

    Scott,
    The new course is awesome. The water for the Guntersville seems to be a bit more rougher than San Diego which is awesome to drive. will make for some really good racing. Can't wait for the Detroit Course. you should use the same water conditions for Detroit. Again you are doing an amazing job with this mod. it keeps getting better and more realistic. I think this is the coolest game ever created. Appreciate all the time and everything you have put into this MOD. Again I can never say Thanks enough.!!!!!!!!



  • Love the new update, the Guntersville course sure is something else! Wonder if your plan is to add more courses as the H1 season goes on (Madison after Madison? Tri-Cities after Tri-Cities?) lol

    Yeah I noticed that bug as well as a sound glitch on the Mission bay course. When you enter the backstretch, the turbine sound becomes "jittery" as it sounds like its either compressor stalling or like the sound file is somehow corrupted on that portion of the course. Once I enter turns 3 and 4, the turbine sound goes back to normal



  • @PeytonHopp "Compressor installing" lol



  • @Beau-Rarig fixed it!


  • registered-users

    @jeffdewalt Yeah I made the water a bit rougher. Eventually I'll make it so the water conditions can be changed.

    @PeytonHopp I haven't had any audio glitches. I wonder if it has something to do with the trees coming into view on the back straight. Detroit will probably be the next course.


  • registered-users

    I fixed the loading issues when switching courses. I was also able to speed up the loading times. I'll post an update after the race today.



  • I can't wait for Tri-Cities and Seattle since we've been waiting for them since 2008. Hint Hint



  • @cp65 wink wink



  • @cp65 🤣 I can’t wait to race on my home course (Tri Cities) please make the first turn like a ocean 😉


Log in to reply
 

Looks like your connection to Unlimited Hydroplane League was lost, please wait while we try to reconnect.